sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-ros / rosdiagnostic / rosdiagnostic-1.9.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros/diagnostics"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="Command to print aggregated diagnostic contents to the command line"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 DEPEND="
18         dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
19         dev-ros/rospy[${PYTHON_USEDEP}]
20 "
21 RDEPEND="${DEPEND}"