41dae056f1c95f9eed76d82c6a871def4e0eae69
[gentoo.git] / dev-ros / roscreate / roscreate-1.14.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/ros"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python2_7 )
9 ROS_SUBDIR=tools/${PN}
10
11 inherit ros-catkin
12
13 DESCRIPTION="Tool that assists in the creation of ROS filesystem resources"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-python/rospkg[${PYTHON_USEDEP}]
20         dev-ros/roslib[${PYTHON_USEDEP}]"
21 DEPEND="${RDEPEND}
22         test? ( dev-python/nose[${PYTHON_USEDEP}] )
23 "