dev-ros/pcl_conversions: Bump to 1.7.1.
[gentoo.git] / dev-ros / roscpp / roscpp-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 ROS_REPO_URI="https://github.com/ros/ros_comm"
7 KEYWORDS="~amd64 ~arm"
8 CATKIN_HAS_MESSAGES=yes
9 ROS_SUBDIR=clients/${PN}
10
11 inherit ros-catkin
12
13 DESCRIPTION="C++ implementation of ROS"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-ros/cpp_common
20         dev-ros/rosconsole
21         dev-ros/roscpp_serialization
22         dev-ros/roscpp_traits
23         dev-ros/rostime
24         dev-ros/xmlrpcpp
25         dev-libs/boost:=
26         dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
27         dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
28 "
29 DEPEND="${RDEPEND}"
30 PATCHES=( "${FILESDIR}/boost173.patch" )