Merge remote-tracking branch 'github/pr/2627'
[gentoo.git] / dev-ros / roscpp / roscpp-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ROS_REPO_URI="https://github.com/ros/ros_comm"
8 KEYWORDS="~amd64 ~arm"
9 CATKIN_HAS_MESSAGES=yes
10 PYTHON_COMPAT=( python{2_7,3_4} )
11 ROS_SUBDIR=clients/${PN}
12
13 inherit ros-catkin
14
15 DESCRIPTION="C++ implementation of ROS"
16 LICENSE="BSD"
17 SLOT="0"
18 IUSE=""
19
20 RDEPEND="
21         dev-ros/cpp_common
22         dev-ros/rosconsole
23         dev-ros/roscpp_serialization
24         dev-ros/roscpp_traits
25         dev-ros/rostime
26         dev-ros/xmlrpcpp
27         dev-libs/boost:=
28         dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
29         dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
30 "
31 DEPEND="${RDEPEND}"