dev-ros/interactive_marker_tutorials: Initial import. Ebuild by me.
[gentoo.git] / dev-ros / rosclean / rosclean-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ROS_REPO_URI="https://github.com/ros/ros"
8 KEYWORDS="~amd64 ~arm"
9 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
10 ROS_SUBDIR=tools/${PN}
11
12 inherit ros-catkin
13
14 DESCRIPTION="Cleanup filesystem resources (e.g. log files)"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
20 DEPEND="${RDEPEND}
21         test? ( dev-python/nose[${PYTHON_USEDEP}] )
22 "
23 PATCHES=( "${FILESDIR}/bb.patch" )