775590dc7d3bc77eb380d7859a3b8accefc93bb5
[gentoo.git] / dev-ros / rosbridge_server / rosbridge_server-0.7.17.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
6 KEYWORDS="~amd64"
7 PYTHON_COMPAT=( python2_7 )
8 ROS_SUBDIR=${PN}
9
10 inherit ros-catkin
11
12 DESCRIPTION="A WebSocket interface to rosbridge"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/rosapi[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
19         dev-ros/rospy[${PYTHON_USEDEP}]
20         dev-ros/rosbridge_library[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
21         dev-ros/rosauth[${PYTHON_USEDEP}]
22         dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]
23         www-servers/tornado[${PYTHON_USEDEP}]
24         "
25 DEPEND="${RDEPEND}"
26 PATCHES=(
27         "${FILESDIR}/backports-ssl.patch"
28         "${FILESDIR}/tornado.patch"
29 )