dev-ros/rosbridge_server: Bump to 0.7.15.
[gentoo.git] / dev-ros / rosbridge_server / rosbridge_server-0.7.13-r2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
7 KEYWORDS="~amd64"
8 PYTHON_COMPAT=( python2_7 )
9 ROS_SUBDIR=${PN}
10
11 inherit ros-catkin
12
13 DESCRIPTION="A WebSocket interface to rosbridge"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-ros/rosapi[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
20         dev-ros/rospy[${PYTHON_USEDEP}]
21         dev-ros/rosbridge_library[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
22         dev-ros/rosauth[${PYTHON_USEDEP}]
23         dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]
24         www-servers/tornado[${PYTHON_USEDEP}]
25         "
26 DEPEND="${RDEPEND}"
27 PATCHES=(
28         "${FILESDIR}/backports-ssl.patch"
29         "${FILESDIR}/tornado.patch"
30 )