dev-python/Babel: Drop old
[gentoo.git] / dev-ros / rosbag / rosbag-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ROS_REPO_URI="https://github.com/ros/ros_comm"
8 KEYWORDS="~amd64 ~arm"
9 ROS_SUBDIR=tools/${PN}
10 PYTHON_COMPAT=( python2_7 )
11
12 inherit ros-catkin
13
14 DESCRIPTION="Set of tools for recording from and playing back to ROS topics"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE="lz4"
18
19 RDEPEND="
20         dev-ros/rosbag_storage
21         dev-ros/rosconsole
22         dev-ros/roscpp
23         dev-ros/topic_tools
24         dev-ros/xmlrpcpp
25         dev-libs/boost:=
26         app-arch/bzip2
27         dev-ros/roslib[${PYTHON_USEDEP}]
28         dev-ros/genpy[${PYTHON_USEDEP}]
29         dev-ros/rospy[${PYTHON_USEDEP}]
30 "
31 DEPEND="${RDEPEND}"
32 RDEPEND="${RDEPEND}
33         lz4? ( dev-ros/roslz4[${PYTHON_USEDEP}] )"