dev-ros/rosgraph: Bump to 1.15.4.
[gentoo.git] / dev-ros / rosbag / rosbag-1.14.3-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/ros_comm"
7 KEYWORDS="~amd64 ~arm"
8 ROS_SUBDIR=tools/${PN}
9 PYTHON_COMPAT=( python2_7 )
10
11 inherit ros-catkin
12
13 DESCRIPTION="Set of tools for recording from and playing back to ROS topics"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE="lz4"
17
18 RDEPEND="
19         >=dev-ros/rosbag_storage-1.14
20         dev-ros/rosconsole
21         dev-ros/roscpp
22         dev-ros/topic_tools
23         dev-ros/xmlrpcpp
24         dev-libs/boost:=
25         app-arch/bzip2
26         dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
27         dev-ros/roslib[${PYTHON_USEDEP}]
28         dev-ros/genpy[${PYTHON_USEDEP}]
29         dev-ros/rospy[${PYTHON_USEDEP}]
30         dev-libs/console_bridge:=
31         dev-python/pycryptodome[${PYTHON_USEDEP}]
32         dev-python/python-gnupg[${PYTHON_USEDEP}]
33 "
34 DEPEND="${RDEPEND}"
35 RDEPEND="${RDEPEND}
36         lz4? ( dev-ros/roslz4[${PYTHON_USEDEP}] )"
37 PATCHES=( "${FILESDIR}/yaml.patch" )