dev-ros/tf2_sensor_msgs: Remove old
[gentoo.git] / dev-ros / robot_state_publisher / robot_state_publisher-1.13.4.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros/robot_state_publisher"
6 KEYWORDS="~amd64 ~arm"
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit ros-catkin
10
11 DESCRIPTION="Package for publishing the state of a robot to tf"
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="
17         dev-ros/kdl_parser
18         dev-cpp/eigen:3
19         sci-libs/orocos_kdl
20         dev-ros/roscpp
21         dev-ros/rosconsole
22         dev-ros/rostime
23         dev-ros/tf2_ros
24         dev-ros/tf2_kdl
25         dev-ros/kdl_conversions
26         dev-ros/sensor_msgs
27         dev-ros/tf
28         dev-ros/urdf
29 "
30 DEPEND="${RDEPEND}
31         dev-ros/rostest[${PYTHON_USEDEP}]
32 "