Drop $Id$ per council decision in bug #611234.
[gentoo.git] / dev-ros / robot_pose_ekf / robot_pose_ekf-9999.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-planning/navigation"
6 ROS_SUBDIR=${PN}
7 KEYWORDS="~amd64 ~arm"
8 CATKIN_HAS_MESSAGES=yes
9 PYTHON_COMPAT=( python2_7 )
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
11
12 inherit ros-catkin
13
14 DESCRIPTION="Estimate the 3D pose of a robot, based on (partial) pose measurements coming from different sources"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-ros/roscpp
21         dev-ros/tf
22         dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
23         dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
24         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
25         sci-libs/orocos-bfl
26         dev-libs/boost:=[threads]
27 "
28 DEPEND="${RDEPEND}
29         test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
30         virtual/pkgconfig"