a2c43b164175e8617a5f896a7a70d1ff1ec2c2cc
[gentoo.git] / dev-ros / robot_pose_ekf / robot_pose_ekf-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-planning/navigation"
7 ROS_SUBDIR=${PN}
8 KEYWORDS="~amd64 ~arm"
9 CATKIN_HAS_MESSAGES=yes
10 PYTHON_COMPAT=( python2_7 )
11 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
12
13 inherit ros-catkin
14
15 DESCRIPTION="Estimate the 3D pose of a robot, based on (partial) pose measurements coming from different sources"
16 LICENSE="BSD"
17 SLOT="0"
18 IUSE=""
19
20 RDEPEND="
21         dev-ros/roscpp
22         dev-ros/tf
23         dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
24         dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
25         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
26         sci-libs/orocos-bfl
27 "
28 DEPEND="${RDEPEND}
29         test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
30         virtual/pkgconfig"