dev-ros/rosserial_xbee: Bump to 0.8.0.
[gentoo.git] / dev-ros / realtime_tools / realtime_tools-1.10.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-controls/realtime_tools"
6 KEYWORDS="~amd64"
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit ros-catkin
10
11 DESCRIPTION="Set of tools that can be used from a hard realtime thread, without breaking the realtime behavior"
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="
17         dev-ros/roscpp
18         dev-ros/rospy[${PYTHON_USEDEP}]
19         dev-libs/boost:=
20 "
21 DEPEND="${RDEPEND}"