dev-ros/visp_bridge: eapi7
[gentoo.git] / dev-ros / qt_dotgraph / qt_dotgraph-0.3.3.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
7 KEYWORDS="~amd64"
8 PYTHON_COMPAT=( python2_7 )
9 ROS_SUBDIR=${PN}
10
11 inherit ros-catkin
12
13 DESCRIPTION="Helpers to work with dot graphs"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-python/pydot[${PYTHON_USEDEP}]
20         >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
21 "
22 DEPEND="${RDEPEND}
23         test? (
24                 dev-python/nose[${PYTHON_USEDEP}]
25                 dev-python/pygraphviz[${PYTHON_USEDEP}]
26         )"