dev-ros/tf2_eigen: initial import; ebuild by me, part of geometry2/geometry_experimental
[gentoo.git] / dev-ros / qt_dotgraph / qt_dotgraph-0.2.30.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
8 KEYWORDS="~amd64"
9 PYTHON_COMPAT=( python2_7 )
10 ROS_SUBDIR=${PN}
11
12 inherit ros-catkin
13
14 DESCRIPTION="Helpers to work with dot graphs"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         media-gfx/pydot[${PYTHON_USEDEP}]
21         dev-ros/python_qt_binding[${PYTHON_USEDEP}]
22 "
23 DEPEND="${RDEPEND}
24         test? (
25                 dev-python/nose[${PYTHON_USEDEP}]
26                 dev-python/pygraphviz[${PYTHON_USEDEP}]
27         )"