dev-ros/pr2_description: Bump to 1.12.0.
[gentoo.git] / dev-ros / pr2_description / pr2_description-1.12.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/pr2/pr2_common"
7 KEYWORDS="~amd64"
8 ROS_SUBDIR=${PN}
9 PYTHON_COMPAT=( python2_7 )
10
11 inherit ros-catkin
12
13 DESCRIPTION="Description (mechanical, kinematic, visual,  etc.) of the PR2 robot"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="dev-ros/xacro[${PYTHON_USEDEP}]"
19 DEPEND="${RDEPEND}
20         dev-ros/convex_decomposition
21         dev-ros/ivcon
22         test? ( dev-libs/urdfdom dev-cpp/gtest )"