Drop $Id$ per council decision in bug #611234.
[gentoo.git] / dev-ros / pr2_description / pr2_description-1.12.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/pr2/pr2_common"
6 KEYWORDS="~amd64"
7 ROS_SUBDIR=${PN}
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="Description (mechanical, kinematic, visual,  etc.) of the PR2 robot"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="dev-ros/xacro[${PYTHON_USEDEP}]"
18 DEPEND="${RDEPEND}
19         dev-ros/convex_decomposition
20         dev-ros/ivcon
21         test? ( dev-libs/urdfdom dev-cpp/gtest )"