dev-ros/pluginlib: bump to 1.11.2
[gentoo.git] / dev-ros / pluginlib / pluginlib-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/pluginlib"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
9
10 inherit ros-catkin
11
12 DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         >=dev-ros/class_loader-0.3.5
19         dev-ros/rosconsole
20         dev-ros/roslib[${PYTHON_USEDEP}]
21         dev-libs/boost:=
22         dev-libs/tinyxml2:=
23         dev-ros/cmake_modules
24 "
25 DEPEND="${RDEPEND}
26         test? ( dev-cpp/gtest )"
27 PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" )