dev-ros/pcl_msgs: add more python support
[gentoo.git] / dev-ros / pcl_msgs / pcl_msgs-0.2.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 CATKIN_HAS_MESSAGES=yes
6 ROS_REPO_URI="https://github.com/ros-perception/pcl_msgs"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
9 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs"
10
11 inherit ros-catkin
12
13 DESCRIPTION="PCL (Point Cloud Library)-related ROS messages"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND=""
19 DEPEND="${RDEPEND}"