Merge remote-tracking branch 'github/pr/180'
[gentoo.git] / dev-ros / octomap_ros / octomap_ros-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/OctoMap/octomap_ros"
7 KEYWORDS="~amd64 ~arm"
8
9 inherit ros-catkin
10
11 DESCRIPTION="Conversion functions between ROS / PCL and OctoMap's native types"
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="
17         dev-ros/tf
18         dev-ros/pcl_ros
19         dev-ros/octomap_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
20         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
21 "
22 DEPEND="${RDEPEND}"