Drop $Id$ per council decision in bug #611234.
[gentoo.git] / dev-ros / nodelet / nodelet-1.9.5.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 CATKIN_HAS_MESSAGES=yes
6 ROS_REPO_URI="https://github.com/ros/nodelet_core"
7 KEYWORDS="~amd64 ~arm"
8 ROS_SUBDIR=${PN}
9 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
10 PYTHON_COMPAT=( python{2_7,3_4} )
11
12 inherit ros-catkin
13
14 DESCRIPTION="Provides a way to run multiple algorithms in the same process with zero copy transport"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-ros/bondcpp
21         dev-ros/cmake_modules
22         dev-ros/pluginlib
23         dev-ros/rosconsole
24         dev-ros/roscpp
25         dev-libs/boost:=
26         sys-apps/util-linux
27 "
28 DEPEND="${RDEPEND}"