app-misc/todo: rename binary due to a collision with another ebuild.
[gentoo.git] / dev-ros / move_slow_and_clear / move_slow_and_clear-1.14.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-planning/navigation"
7 ROS_SUBDIR=${PN}
8 KEYWORDS="~amd64 ~arm"
9
10 inherit ros-catkin
11
12 DESCRIPTION="Move slow and clear"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/roscpp
19         dev-ros/nav_core
20         dev-ros/costmap_2d
21         dev-ros/actionlib_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
22         dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
23         dev-ros/pluginlib
24         dev-libs/boost:=[threads]
25         dev-cpp/eigen:3
26         sci-libs/pcl
27 "
28 DEPEND="${RDEPEND}
29         dev-ros/cmake_modules
30
31 "