dev-ros/visp_hand2eye_calibration: Remove old
[gentoo.git] / dev-ros / move_base / move_base-1.15.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-planning/navigation"
6 ROS_SUBDIR=${PN}
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="Given a goal in the world, will attempt to reach it with a mobile base"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         >=dev-ros/costmap_2d-1.15.1
19         dev-ros/roscpp
20         dev-ros/pluginlib
21                 dev-libs/tinyxml2:=
22         dev-ros/actionlib
23         dev-ros/base_local_planner
24         dev-ros/clear_costmap_recovery
25         dev-ros/navfn
26         dev-ros/rotate_recovery
27         dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
28         dev-ros/nav_core
29         dev-ros/tf
30         dev-ros/move_base_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
31         dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
32         dev-cpp/eigen:3
33         dev-libs/boost:=
34         dev-libs/console_bridge:=
35 "
36 DEPEND="${RDEPEND}
37         dev-ros/cmake_modules"