dev-ros/map_server: Bump to 1.14.0.
[gentoo.git] / dev-ros / map_server / map_server-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-planning/navigation"
7 ROS_SUBDIR=${PN}
8 KEYWORDS="~amd64 ~arm"
9
10 inherit ros-catkin
11
12 DESCRIPTION="Offers map data as a ROS service"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/roscpp
19         dev-ros/tf
20         dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
21         dev-libs/boost:=
22         media-libs/sdl-image
23         >=dev-cpp/yaml-cpp-0.5
24 "
25 DEPEND="${RDEPEND}
26         test? ( dev-ros/rostest dev-cpp/gtest )
27         virtual/pkgconfig"