dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ros / laser_geometry / laser_geometry-1.6.4.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-perception/laser_geometry"
6 KEYWORDS="~amd64 ~arm"
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit ros-catkin
10
11 DESCRIPTION="Class for converting from a 2D laser scan into a point cloud"
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="
17         dev-ros/roscpp
18         dev-ros/rospy[${PYTHON_USEDEP}]
19         dev-python/numpy[${PYTHON_USEDEP}]
20         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
21         dev-libs/boost:=[threads]
22         dev-ros/tf
23         dev-ros/tf2_ros[${PYTHON_USEDEP}]
24         dev-cpp/eigen:3
25         dev-ros/angles
26 "
27 DEPEND="${RDEPEND}
28         dev-ros/cmake_modules
29         test? ( dev-python/nose[${PYTHON_USEDEP}] )"