Unify quoting in metadata.xml files for machine processing
[gentoo.git] / dev-ros / laser_geometry / laser_geometry-1.6.4.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-perception/laser_geometry"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="Class for converting from a 2D laser scan into a point cloud"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/roscpp
19         dev-ros/rospy[${PYTHON_USEDEP}]
20         dev-python/numpy[${PYTHON_USEDEP}]
21         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
22         dev-libs/boost:=[threads]
23         dev-ros/tf
24         dev-ros/tf2_ros[${PYTHON_USEDEP}]
25         dev-cpp/eigen:3
26         dev-ros/angles
27 "
28 DEPEND="${RDEPEND}
29         dev-ros/cmake_modules
30         test? ( dev-python/nose[${PYTHON_USEDEP}] )"