dev-ros/laser_assembler: bump to 1.7.4
[gentoo.git] / dev-ros / laser_assembler / laser_assembler-1.7.4.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-perception/laser_assembler"
7 CATKIN_HAS_MESSAGES=yes
8 KEYWORDS="~amd64 ~arm"
9 PYTHON_COMPAT=( python2_7 )
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs"
11
12 inherit ros-catkin
13
14 DESCRIPTION="Nodes to assemble point clouds from either LaserScan or PointCloud messages"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-ros/roscpp
21         dev-libs/boost:=
22         dev-ros/tf
23         dev-ros/laser_geometry[${PYTHON_USEDEP}]
24         dev-ros/pluginlib
25         dev-ros/message_filters[${PYTHON_USEDEP}]
26         dev-ros/filters
27 "
28 DEPEND="${RDEPEND}
29         test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
30 "