dev-ros/openni2_launch: add usbutils dep
[gentoo.git] / dev-ros / kdl_parser / kdl_parser-9999.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros/kdl_parser"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="Constructs a KDL tree from an XML robot representation in URDF"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-libs/boost:=
19         dev-ros/roscpp
20         dev-ros/rosconsole
21         >=dev-ros/urdf-1.13
22         sci-libs/orocos_kdl:=
23         dev-libs/tinyxml2:=
24 "
25 DEPEND="${RDEPEND}
26         test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"