dev-ros/rqt_nav_view: Bump to 0.5.3.
[gentoo.git] / dev-ros / interactive_markers / interactive_markers-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ROS_REPO_URI="https://github.com/ros-visualization/interactive_markers"
8 KEYWORDS="~amd64"
9 PYTHON_COMPAT=( python2_7 )
10
11 inherit ros-catkin
12
13 DESCRIPTION="3D interactive marker communication library for RViz and similar tools"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
20         dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
21         dev-ros/tf
22         dev-ros/rospy[${PYTHON_USEDEP}]
23         dev-ros/roscpp
24         dev-ros/rosconsole
25         dev-ros/rostest[${PYTHON_USEDEP}]
26 "
27 DEPEND="${RDEPEND}
28         test? ( dev-cpp/gtest )"