dev-ros/imu_filter_madgwick: initial import
[gentoo.git] / dev-ros / imu_filter_madgwick / imu_filter_madgwick-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
7 KEYWORDS="~amd64"
8 ROS_SUBDIR=${PN}
9
10 inherit ros-catkin
11
12 DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/roscpp
19         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
20         dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
21         dev-ros/tf2
22         dev-ros/tf2_geometry_msgs
23         dev-ros/tf2_ros
24         dev-ros/nodelet
25         dev-ros/pluginlib
26         dev-ros/message_filters
27         dev-ros/dynamic_reconfigure
28         dev-libs/boost:=[threads]
29 "
30 DEPEND="${RDEPEND}
31         test? ( dev-ros/rosunit )
32 "