sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-ros / imu_complementary_filter / imu_complementary_filter-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
7 KEYWORDS="~amd64"
8 ROS_SUBDIR=${PN}
9
10 inherit ros-catkin
11
12 DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/message_filters
19         dev-ros/roscpp
20         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
21         dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
22         dev-ros/tf
23         dev-libs/boost:=
24 "
25 DEPEND="${RDEPEND}
26         dev-ros/cmake_modules
27 "