dev-python/Babel: Drop old
[gentoo.git] / dev-ros / image_view / image_view-1.12.14.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python2_7 )
9 ROS_SUBDIR=${PN}
10
11 inherit ros-catkin
12
13 DESCRIPTION="Simple viewer for ROS image topics"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-libs/boost:=[threads]
20         media-libs/opencv
21         x11-libs/gtk+:2
22         dev-ros/camera_calibration_parsers
23         dev-ros/cv_bridge
24         dev-ros/image_transport
25         dev-ros/message_filters
26         dev-ros/nodelet
27         dev-ros/rosconsole
28         dev-ros/roscpp
29 "
30 DEPEND="${RDEPEND}"