dev-haskell/stm: bump up to 2.5.0.0 (ghc-8.6 core lib)
[gentoo.git] / dev-ros / image_publisher / image_publisher-1.12.23.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
6 KEYWORDS="~amd64 ~arm"
7 PYTHON_COMPAT=( python2_7 )
8 ROS_SUBDIR=${PN}
9
10 inherit ros-catkin
11
12 DESCRIPTION="Publish an image stream from single image file or avi file."
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/cv_bridge
19         media-libs/opencv:=
20         dev-ros/dynamic_reconfigure
21         dev-ros/camera_info_manager
22         dev-ros/image_transport
23         dev-ros/nodelet
24         dev-libs/console_bridge:=
25         dev-ros/roscpp
26         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
27         dev-libs/boost:=
28 "
29 DEPEND="${RDEPEND}"