dev-ros/openni2_camera: bump to 0.2.6
[gentoo.git] / dev-ros / image_proc / image_proc-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python2_7 )
9 ROS_SUBDIR=${PN}
10
11 inherit ros-catkin
12
13 DESCRIPTION="Single image rectification and color processing"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-ros/cv_bridge
20         dev-ros/dynamic_reconfigure
21         dev-ros/image_geometry
22         dev-ros/image_transport
23         dev-ros/nodelet
24         dev-ros/roscpp
25         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
26         media-libs/opencv
27         dev-libs/boost:=[threads]
28 "
29 DEPEND="${RDEPEND}"