dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ros / image_proc / image_proc-1.13.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
6 KEYWORDS="~amd64 ~arm"
7 PYTHON_COMPAT=( python2_7 )
8 ROS_SUBDIR=${PN}
9
10 inherit ros-catkin
11
12 DESCRIPTION="Single image rectification and color processing"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/cv_bridge
19         dev-ros/dynamic_reconfigure
20         dev-ros/image_geometry
21         dev-ros/image_transport
22         dev-ros/nodelet
23         dev-libs/console_bridge:=
24         dev-ros/roscpp
25         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
26         media-libs/opencv:=
27         dev-libs/boost:=[threads]
28 "
29 DEPEND="${RDEPEND}"