dev-python/Babel: Drop old
[gentoo.git] / dev-ros / geometric_shapes / geometric_shapes-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-planning/geometric_shapes"
7 KEYWORDS="~amd64 ~arm"
8
9 inherit ros-catkin
10
11 DESCRIPTION="Generic definitions of geometric shapes and bodies"
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="
17         dev-libs/boost:=
18         media-libs/qhull
19         media-libs/assimp
20         sci-libs/octomap
21         dev-ros/random_numbers
22         dev-ros/resource_retriever
23         dev-ros/eigen_stl_containers
24         dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
25         dev-ros/shape_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
26 "
27 DEPEND="${RDEPEND}
28         test? ( dev-cpp/gtest )
29 "
30
31 src_prepare() {
32         sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
33                 -i CMakeLists.txt \
34                 || die
35         ros-catkin_src_prepare
36 }