Revert "app-office/taskcoach: Add missing dependency (#554466)"
[gentoo.git] / dev-ros / genpy / genpy-0.5.9.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ROS_REPO_URI="https://github.com/ros/genpy"
8 KEYWORDS="~amd64 ~arm"
9 PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
10
11 inherit ros-catkin
12
13 DESCRIPTION="Python ROS message and service generators"
14 HOMEPAGE="http://wiki.ros.org/genpy"
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 IUSE=""
18
19 RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
20 DEPEND="${RDEPEND}
21         test? (
22                 dev-python/pyyaml[${PYTHON_USEDEP}]
23                 dev-python/nose[${PYTHON_USEDEP}]
24         )
25 "