a01c8a682048e3bab340f5c43bd72bd87e0db539
[gentoo.git] / dev-ros / gazebo_plugins / gazebo_plugins-2.6.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
7 KEYWORDS="~amd64"
8 PYTHON_COMPAT=( python2_7 )
9 CATKIN_HAS_MESSAGES=yes
10 ROS_SUBDIR=${PN}
11
12 inherit ros-catkin
13
14 DESCRIPTION="Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components"
15 LICENSE="BSD Apache-2.0"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
21         dev-ros/roscpp
22         dev-ros/rospy
23         dev-ros/nodelet
24         dev-ros/angles
25         dev-ros/std_srvs
26         dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
27         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
28         dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
29         dev-ros/urdf
30         dev-ros/tf
31         dev-ros/tf2_ros
32         dev-ros/dynamic_reconfigure
33         dev-ros/driver_base
34         dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
35         dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
36         dev-ros/pcl_conversions
37         dev-ros/image_transport
38         dev-ros/rosconsole
39         dev-ros/cv_bridge
40         dev-ros/polled_camera
41         dev-ros/diagnostic_updater
42         dev-ros/camera_info_manager
43         dev-ros/moveit_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
44         dev-libs/libxml2
45         >=sci-electronics/gazebo-7:=
46         dev-games/ogre
47         sci-libs/pcl
48         dev-libs/boost:=
49         dev-qt/qtcore:4
50         dev-qt/qtgui:4
51         dev-ros/roslib[${PYTHON_USEDEP}]
52 "
53 DEPEND="${RDEPEND}"