dev-ruby/minitest-bonus-assertions: add missing test dependency
[gentoo.git] / dev-ros / dwa_local_planner / dwa_local_planner-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-planning/navigation"
7 ROS_SUBDIR=${PN}
8 KEYWORDS="~amd64 ~arm"
9 PYTHON_COMPAT=( python2_7 )
10
11 inherit ros-catkin
12
13 DESCRIPTION="Dynamic Window Approach to local robot navigation on a plane"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-ros/base_local_planner
20         dev-ros/costmap_2d
21         dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
22         dev-ros/nav_core
23         dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
24         dev-ros/pluginlib
25         dev-ros/pcl_conversions
26         dev-ros/roscpp
27         dev-ros/tf
28         dev-cpp/eigen:3
29         sci-libs/pcl
30 "
31 DEPEND="${RDEPEND}"