dev-ros/move_base: Bump to 1.16.6.
[gentoo.git] / dev-ros / dwa_local_planner / dwa_local_planner-1.16.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-planning/navigation"
6 ROS_SUBDIR=${PN}
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="Dynamic Window Approach to local robot navigation on a plane"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/angles
19         dev-ros/base_local_planner
20         dev-ros/costmap_2d
21         dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
22         dev-cpp/eigen:3
23         dev-ros/nav_core
24         dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
25         dev-ros/pluginlib
26         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
27         dev-ros/roscpp
28
29         dev-ros/tf2
30         dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
31         dev-ros/tf2_ros
32
33         dev-libs/boost:=[threads]
34         dev-libs/console_bridge:=
35 "
36 DEPEND="${RDEPEND}"