dev-python/Babel: Drop old
[gentoo.git] / dev-ros / driver_base / driver_base-1.6.8.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-drivers/driver_common"
7 CATKIN_HAS_MESSAGES=yes
8 KEYWORDS="~amd64 ~arm"
9 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
10 ROS_SUBDIR=${PN}
11 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
12
13 inherit ros-catkin
14
15 DESCRIPTION="Framework for writing drivers that helps with runtime reconfiguration, diagnostics and self-test"
16 LICENSE="BSD"
17 SLOT="0"
18 IUSE=""
19
20 RDEPEND="dev-libs/boost:="
21 DEPEND="${RDEPEND}"