dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-ros / diagnostic_common_diagnostics / diagnostic_common_diagnostics-1.8.10.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros/diagnostics"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="Generic nodes for monitoring a linux host"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 DEPEND="
18         dev-ros/diagnostic_updater[${PYTHON_USEDEP}]
19         dev-ros/roslib[${PYTHON_USEDEP}]
20         dev-ros/rospy[${PYTHON_USEDEP}]
21         dev-ros/tf[${PYTHON_USEDEP}]
22 "
23 RDEPEND="${DEPEND}
24         app-admin/hddtemp"