app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / dev-ros / diagnostic_aggregator / diagnostic_aggregator-1.8.9.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros/diagnostics"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8
9 inherit ros-catkin
10
11 DESCRIPTION="Aggregates ROS diagnostics"
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="
17         dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
18         dev-ros/pluginlib
19         dev-ros/roscpp
20         dev-ros/rospy
21         dev-ros/rostest
22         dev-ros/xmlrpcpp
23         dev-ros/bondcpp
24         dev-libs/boost:=
25 "
26 DEPEND="${RDEPEND}
27         test? ( dev-ros/rostest )"