Merge remote-tracking branch 'remotes/github/pr/979'
[gentoo.git] / dev-ros / diagnostic_aggregator / diagnostic_aggregator-1.8.8.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros/diagnostics"
7 KEYWORDS="~amd64 ~arm"
8 ROS_SUBDIR=${PN}
9
10 inherit ros-catkin
11
12 DESCRIPTION="Aggregates ROS diagnostics"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
19         dev-ros/pluginlib
20         dev-ros/roscpp
21         dev-ros/rospy
22         dev-ros/rostest
23         dev-ros/xmlrpcpp
24         dev-libs/boost:=
25 "
26 DEPEND="${RDEPEND}
27         test? ( dev-ros/rostest )"