Fixed CPE tag for sys-libs/libseccomp
[gentoo.git] / dev-ros / depthimage_to_laserscan / depthimage_to_laserscan-1.0.7-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
6 KEYWORDS="~amd64 ~arm"
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit ros-catkin
10
11 DESCRIPTION="Converts a depth image to a laser scan for use with navigation and localization"
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="
17         dev-ros/roscpp
18         media-libs/opencv:=
19         dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
20         dev-ros/image_geometry
21         dev-ros/image_transport
22         dev-ros/nodelet
23         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
24         dev-libs/boost:=
25         dev-libs/console_bridge:=
26 "
27 DEPEND="${RDEPEND}"
28 PATCHES=( "${FILESDIR}/isnan.patch" "${FILESDIR}/pluginlib.patch" )