dev-ros/cv_bridge: fix boost python detection
[gentoo.git] / dev-ros / cv_bridge / cv_bridge-1.13.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
6 KEYWORDS="~amd64 ~arm"
7 PYTHON_COMPAT=( python2_7 )
8 ROS_SUBDIR=${PN}
9
10 inherit ros-catkin
11
12 DESCRIPTION="Converts between ROS Image messages and OpenCV images"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/rosconsole
19         >=media-libs/opencv-3:=[contrib(+)]
20         dev-libs/boost:=[threads,python,${PYTHON_USEDEP}]
21         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
22 "
23 DEPEND="${RDEPEND}"
24 PATCHES=( "${FILESDIR}/boostpython.patch" )