media-gfx/splash-themes-livecd: Merge gentoo-functions use fix
[gentoo.git] / dev-ros / costmap_2d / costmap_2d-1.13.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-planning/navigation"
7 ROS_SUBDIR=${PN}
8 KEYWORDS="~amd64 ~arm"
9 CATKIN_HAS_MESSAGES=yes
10 PYTHON_COMPAT=( python2_7 )
11 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/map_msgs"
12
13 inherit ros-catkin
14
15 DESCRIPTION="Creates a 2D costmap from sensor data"
16 LICENSE="BSD"
17 SLOT="0"
18 IUSE=""
19 REQUIRED_USE="ros_messages_cxx"
20
21 RDEPEND="
22         dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
23         dev-ros/laser_geometry
24         dev-ros/message_filters
25         dev-ros/nav_msgs
26         dev-ros/pcl_conversions
27         dev-ros/pcl_ros
28         dev-ros/pluginlib
29         dev-ros/roscpp
30         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
31         dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
32         dev-ros/tf
33         dev-ros/voxel_grid
34         dev-cpp/eigen:3
35         sci-libs/pcl
36         dev-libs/boost:=[threads]
37 "
38 DEPEND="${RDEPEND}
39         dev-ros/cmake_modules
40         test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"