sys-freebsd: Merge multiple errata fixes
[gentoo.git] / dev-ros / control_toolbox / control_toolbox-1.14.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-controls/control_toolbox"
7 KEYWORDS="~amd64"
8 CATKIN_HAS_MESSAGES=yes
9 PYTHON_COMPAT=( python2_7 )
10
11 inherit ros-catkin
12
13 DESCRIPTION="Modules that are useful across all controllers"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-ros/roscpp
20         dev-ros/dynamic_reconfigure
21         dev-ros/realtime_tools
22         dev-ros/std_msgs
23         dev-libs/boost:=[threads]
24         dev-libs/tinyxml
25 "
26 DEPEND="${RDEPEND}"