dev-db/libiodbc: stable 3.52.12 for sparc, bug #676450
[gentoo.git] / dev-ros / control_toolbox / control_toolbox-1.14.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-controls/control_toolbox"
6 KEYWORDS="~amd64"
7 CATKIN_HAS_MESSAGES=yes
8 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
9 PYTHON_COMPAT=( python2_7 )
10
11 inherit ros-catkin
12
13 DESCRIPTION="Modules that are useful across all controllers"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-ros/roscpp
20         dev-ros/dynamic_reconfigure
21         dev-ros/realtime_tools
22         dev-libs/boost:=[threads]
23         dev-libs/tinyxml
24         dev-ros/control_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
25 "
26 DEPEND="${RDEPEND}"