dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-ros / compressed_depth_image_transport / compressed_depth_image_transport-1.9.5-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="Plugin to image_transport for transparently sending depth images using PNG compression"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/cv_bridge
19         dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
20         dev-ros/image_transport
21         >=media-libs/opencv-4:=
22         dev-libs/boost:=
23         dev-libs/console_bridge:=
24 "
25 DEPEND="${RDEPEND}"
26 PATCHES=( "${FILESDIR}/ocv4.patch" )